We will disable access to TINYpulse over Transport Layer Security (TLS) 1.0 and 1.1 in October 2019 to align with security best practices. 


Most of you won’t be affected since you are already using clients that support TLS 1.2. However, if you are using an outdated browser, then you might want to upgrade your browser. 


What is TLS?


TLS, or Transport Layer Security, is a protocol that secures data transmitted between two applications. It is the standard security protocol used by all major browsers and other applications that require secure data transmission.


What is changing?


Starting in October 2019, TINYpulse will refuse all connections over TLS 1.0 and 1.1. Only connections over TLS 1.2 will be accepted when you try to log in to the web app. 


How will this impact me?


For most users, this will have no visible impact if you’re using the latest version of your browser.


Why is this changing?


TLS 1.0 and 1.1 are outdated versions of the TLS protocol. By restricting access to TLS 1.2, we are aligning with security best practices to protect against any vulnerabilities that may arise in these outdated protocols.


What browsers are affected by this change?


The following is a list of minimum browser versions for TLS 1.2 support:

  • Internet Explorer 11+ 
  • Edge, all versions
  • Firefox 27+
  • Chrome 38+
  • Android 5.0+ (Lollipop) and some 4.4 (KitKat) clients
  • Desktop Safari 7+ (OS X 10.9+)
  • Mobile Safari 5+ (iOS 5+)


If you attempt to access TINYpulse on an outdated browser, you may receive a security error.