TINYpulse gives you the flexibility to use a variety of popular browsers, however, only certain versions are supported. Make sure you're on the most current browser versions possible for the best TINYpulse experience.


We fully support:


  • Internet Explorer 11
  • Chrome 51 and above
  • Safari
  • Firefox 47 and above
  • Edge 13 and above


All other browsers are unsupported and service is not guaranteed. Users (both from the admin and employee side) may experience an unappealing user interface and/or decreased functionality by using an unsupported browser. Everyone on an unsupported browser will be automatically redirected to the old Engage user interface with a permanent banner to update the browser for additional functionality.


So update your browser already so you can take advantage of the latest and greatest TINYpulse functionality! You're definitely missing out (and losing money) if you're on an older version so update today or talk to the IT administrator at your company for assistance.